ciscofirewall#wr t
Building configuration...

Current configuration : 1818 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ciscofirewall
!
boot-start-marker
boot-end-marker
!
security authentication failure rate 3 log
enable secret 5 $1$mr8K$zZxXMDYifZmznYMktdWkK/
!
aaa new-model
!
!
!
aaa session-id common
!
resource policy
!
ip subnet-zero
!
!
!
!
ip cef
no ip domain lookup
ip domain name frank4dd.com
!
!
!
username cisco secret 5 $1$mPZK$Y0iWwB0tEC98GsRRHEI3K/
!
!
!
crypto isakmp policy 1
 encr 3des
 hash md5
 authentication pre-share
 group 2
crypto isakmp key dobsekred address 128.12.2.10
!
crypto ipsec security-association lifetime seconds 28800
!
crypto ipsec transform-set myset esp-3des esp-sha-hmac
!
crypto map mymap 10 ipsec-isakmp
 set peer 128.12.2.10
 set security-association level per-host
 set transform-set myset
 match address 102
!
!
!
interface Ethernet0
 description inside
 ip address 192.168.1.103 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 no cdp enable
!
interface Ethernet1
 description outside
 ip address 128.12.1.155 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 duplex auto
 no cdp enable
 crypto map mymap
!
interface Ethernet2
 no ip address
 shutdown
!
interface FastEthernet1
 duplex auto
 speed auto
!
interface FastEthernet2
 duplex auto
 speed auto
!
interface FastEthernet3
 duplex auto
 speed auto
!
interface FastEthernet4
 duplex auto
 speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 128.12.1.10
!
ip http server
no ip http secure-server
!
ip nat inside source list 1 interface Ethernet1 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 102 permit ip host 128.12.1.155 128.12.3.0 0.0.0.255
!
!
control-plane
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
!
scheduler max-task-time 5000
end

Back to main article